• Ubuntuに関連したハード、ソフトの備忘録サイトです

「CodeIgniter徹底入門」の2.x系への対応(4)ー2.2系列でも動作


「CodeIgniter徹底入門」の2.x系への対応の1から3までの変更を施せば、CodeIgniter2.2系列でも動作するようです。簡易ショッピングサイトの機能を一通り試してみました。

ただし、CodeIgniter2.2系列は日本語版がないので、/system/lauguageに2.0.3のjapaneseディレクトリをそのままコピーしています。これで良いかどうかは定かではありません。

config.php、database.phpの設定はもちろんひつようです。とくに、cssやjs、imgを読み込むためconfig.phpでご自身の環境に併せて$config[‘base_url’]の設定が必要になります。

なお、こちらhttps://github.com/bcit-ciにCodeIgniter3.0系列の日本語サイト作成用の言語パッケージが掲載されています。CodeIgniterは兎に角、学習コストが低い。「CodeIgniter徹底入門」はサンプル例題が秀逸です。随分前に購入しましたが、ロクに読みもしなかったのですが、これが最大の失敗です。

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA